Twitter Profile
salta alla navigazione

Errore Svchost.exe…vi riscrivo la possibile soluzione 19 novembre 2007

Inviato da LukePet in : Chicche, Guide, Informatica, Servizi, Soluzioni, Windows , trackback

Da un commento sul blog mi sono reso conto che la pagina che avevo linkato nel post chicche-errore-svchost-exe-vi-segnalo-una-possibile-soluzione non è più accessibile.

Allora tagliamo la testa al toro…vi riscrivo la possibile procedura di risoluzione per il problema.

  1. Andate su Start -> Esegui e digitate il comando services.msc (si aprirà la finestra per la gestione dei servizi di sistema)
  2. Verificate i servizi “Aggiornamenti Automatici” e “Servizio di Trasferimento Intelligente in Background”…devono essere eseguiti con l’account di sistema locale e non deve essere spuntata l’opzione “Consenti al servizio di interagire con il desktop”
  3. Tornate su Start-> Esegui, questa volta eseguite il comando REGSVR32 #PARAMETRO#; al posto dell’etichetta #PARAMETRO# devono essere processate in sequenza le seguenti voci:
    • WUAUENG.DLL
      (per intenderci dovere eseguire REGSVR32 WUAUENG.DLL e così per tutte le successive voci)
    • WUAUENG1.DLL
    • ATL.DLL
    • WUCLTUI.DLL
    • WUPS.DLL
    • WUPS2.DLL
    • WUWEB.DLL
  4. Ora dovete pulire la cartella degli aggiornamenti, svolgete in successione queste tre operazioni:
    • Sempre da Start -> Esegui eseguite il comando
      net stop WuAuServ (in questo modo fermate il servizio Update)
    • Rinominate la cartella C:\WINDOWS\SoftwareDistribution
      (ad esempio in C:\WINDOWS\SoftwareDistribution_OLD)
    • Tornate su Start -> Esegui e questa volta eseguite
      net start WuAuServ (riavvierete così il servizio Update)
  5. A questo punto non vi resta che riavviare il PC e pregate che tutto torni alla normalità.

In bocca al lupo.

  • eddy

    Grazie! l’errore al svchost è sparito…
    Peccato però che ora sia afflitto da WUAUCTL.EXE che sembra essere uno degli oggetti per la ricerca degli aggiornamenti automatici di XP ..:(
    Sto cercando sualla rete ma non so a che santo votarmi!
    Se, spero di no per tte, avessi avuto anche questo problema ed avessi trovato la soluzione faresti cosa gradit a postarmelo.
    Grazie

  • Purtroppo al momento non ho avuto mai a che fare con questo tipo di errore…se mi capiterà di affrontarlo non mancherò di postare sul blog eventuali soluzioni.

  • Luca Papa

    I miei complimenti per la soluzione !!!
    Io avevo il problema che il servizio svchost mi occupava il 99/100% della cpu, non riuscendo cmq a scaricare gli aggiornamenti Microsoft… ho cercato su google varie soluzioni… persino una patch della microsoft ho installato senza soluzione, e l’ho risolto solo con le tue indicazioni, quindi grazie e ricomplimenti.

    Se hai voglia di rispondermi ho alcune curiosità…
    Premessa: io sono un programmatore e non un tecnico o sistemista, quindi:
    Come mai hai consigliato di registrate tutte quelle dll ?? cosa che comunque ho fatto anch’io.
    Non bastava rinominare la cartella “C:\WINDOWS\SoftwareDistribution” ??

    … Sto notando che il “tuo” sito mi sembra interessantissimo e sicuramente molto ben fatto e curato… lo terrò d’occhio.
    Ciao e grazie ancora.

  • Guarda, come ho scritto nel post non ho fatto altro che riportare una soluzione che avevo trovato sul web.
    In un altro post avevo segnalato il link alla soluzione ma poi ad un certo punto il sito era diventato irraggiungibile e così l’ho riscritta io.

    Cmq grazie per i complimenti…torna quando vuoi a far visita al blog.

  • Claudio

    io non ho risolto il problema: mi fallisce alcune voci del 3° punto e sul mio PC non esiste la cartella C:\WINDOWS\SoftwareDistribution!
    aiuto…… :-S

  • ginky

    sopratutto non mi permette di rinominare la cartella

  • Eh, questo non so da cosa possa dipendere…l’unico consiglio che posso darvi è di provare tutto in modalità provvisoria.

  • mik

    un grazie a lukePet anche se ho fallito per il parametro WUPS2 e non so quanto reggerà il sistema. Cmq sto navigando da un bel po’ . Ancora grazie. Michele

  • DAL CERO CLARA

    AIUTO! CON I PROGRAMMI SONO PROPRIO A ZERO MA HO CAPITO DI AVERE LO STESSO PROBLEMA DI SVCHOST.EXE, HO PROVATO LA TUA PROCEDURA MA AL COMANDI (IN ESEGUI) “REGSVR32#PARAMETRO# MI DICE CHE NON LO TROVA.

    MA PIù SEMPLICEMENTE NEL PROGRAMMA IMPOSTAZIONI HO TROVATO DEI PROGRAMMI STRANI CON IL SIMBOLO COMPUTERINO DAVANTI E POI “SHOCKWARE”, DI QUESTI PROGRAMMI NON MI DICE NEMMENO LA FREQUENZA DI UTILIZZO E LE DATE DELL’ULTIMO UTILIZZO, POSSO CANCELLARLI O SONO PARTI DI WINDOWS XP?

    SCUSA PER IL DISTURBO, SE MI RISPONDI SEI VERAMENTE GENTILE

  • Si li puoi anche disinstallare ma non so se dipenda da loro.

  • Vash

    ottima soluzione..ne avevo trovate altre ma nessuna funzionava..
    testavo la macchina ripetutamente con procexp: era una dll che quando cercava nuovi aggiornamenti o li stava installando rendeva il mio computer inutilizzabile!!causa microsoft..
    ma perchè questo strano malfunzionamento?e così facendo l’autoagiornamento rimane attivo?
    ps.grazie, stavo davvero sclerando negli ultimi giorni

  • link_89

    io ho risolto così:
    Start -> Esegui, digitare services.msc (si aprirà la finestra per la gestione dei servizi di sistema)
    ho arrestato i servizi “Aggiornamenti Automatici” e “Servizio di Trasferimento Intelligente in Background”… poi ho fatto la procedura regsvr32 con i parametri… ma NON ho riattivato i servizi “Aggiornamenti Automatici” e “Servizio di Trasferimento Intelligente in Background”…
    ah, il “Servizio di Trasferimento Intelligente in Background” è WUAUCTL.EXE…
    ciao

  • Anonimo

    Ho provato anche io la tua “terapia” e sembra funzionare.
    Vorrei pero saoere come fare a ripristinare tutti i servizi di cui al punto 3.
    grazie
    ciao
    willy

  • maoetao

    Ciao Lukepet, mi associo anch’io ai complimenti..avevo lo stesso problema e ora sembra che il mio pc sia guarito! Il fatto ,però, è che ho lo stesso messaggio di errore (l’istruzione ha fatto riferimento a….la memoria non poteva essere written) anche da skype.exe…ho provato a contattare il servzio clienti skype, ma non mi hanno risposto: avrai mica la soluzione anche di questo errore? Se sì, ti sarei immensamente grato…

  • monia

    complimenti e grazie mille!

  • Anonimo

    Ciao. Ho appena seguito alla lettera la lo soluzione di cui sopra. Spero bene. Il mio problema è un’ errore di svchst che si verificava non sistematicamente dopo un po di tempo che ero connesso.
    Faccio sapere se risolto!!!

  • michael

    grazie comunque per l’impegno ^^ ora sto riprovando vediamo se funziona il tuo consiglio! meno male che ci sono persone come te! ciao

  • Andrea

    Grazie per la soluzione del problema solamente che dopo qualche giorno il problema mi ricompare. Come mai? Cosa posso fare?

  • mmm…non è facile dire quale possa essere la causa. forse c’è qualche aggiornamento di Windows che crea problemi, ma così su due piedi non saprei dirti con certezza.