Twitter Profile
salta alla navigazione

Ubuntu: Feisty, Ati e Compiz…e non ci lasceremo mai! 22 aprile 2007

Inviato da LukePet in : Chicche, Linux, Software , trackback

Dunque….dove eravamo rimasti?….Ah si, avevo appena installato Feisty.

Vi avevo detto che con i driver non proprietari gli effetti desktop funzionavano ma che questi driver mi sembravano un pò instabili e meno performanti di quelli proprietari.

Oggi sono riuscito a far girare gli effetti desktop con i driver fglrx (proprietari); come?…utilizzando il server grafico Xgl (Aiglx non è supportato dai driver proprietari).

Allora, procediamo con ordine:

  • Prima di tutto dovete abilitare i driver proprietari per la scheda Ati. Con Feisty è semplicissimo: andate su “Sistema -> Amministrazione -> Gestore driver con restrizioni” ed abilitate il driver…al termine dell’installazione del driver sarà necessario riavviare il sistema.
  • Al riavvio dovreste avere il driver proprietario abilitato; per verificarlo potete andare sul terminale ed eseguire il comando fglrxinfo da cui dovreste leggere le informazioni sulla vostra scheda video. Per verificare che l’accelerazione 3D sia abilitata potete eseguire il comando fgl_glxgears (una applicazione in 3D che mostra un cubo in rotazione con delle ruote che girano al suo interno dovrebbe essere visualizzata sullo schermo) e/o eseguire il comando glxinfo | grep render (tra le informazioni stampate dovreste leggere direct rendering: yes)…ok ci siamo, a questo punto i driver sono attivi.
  • Se provate ad abilitare gli effetti desktop vedrete che non funzionano, dobbiamo quindi utilizzare il server Xgl. Io ho seguito questo tutorial: Ubuntuforums (xgl+feisty); in questa guida viene spiegato come generare una sessione di Gnome che utilizzi il motore grafico Xgl e sfrutti Beryl per gli effetti. Io ho seguito la guida solo nella parte che concerne l’impostazione della sessione Xgl, tralasciando l’installazione di Beryl in quanto voglio utilizzare Compiz (già installato in Feisty).
  • Una volta definita la sessione Xgl riavviate la grafica e scegliete dalle opzioni “Gnome with Xgl” come sessione per il login.

Se tutto è andato a buon fine avrete i vostri effetti desktop in funzione con i driver proprietari Ati.

NB: Utilizzando Xgl è probabile che alcuni tasti della tastiera non funzionino correttamente, cioè i simboli digitati non coincidono con quelli stampati….niente paura…per riportare tutto in ordine dovrete andare in “Sistema -> Preferenze -> Tastiera -> Disposizioni -> Aggiungi -> Italia – tasti muti rimossi” e impostarlo come predefinito. Riavviate la grafica e tutto funzionerà bene.

Se volete una grafica ancora più accattivante vi consiglio di seguire questo tutorial per migliorare la leggibilità dei caratteri sul monitor LCD: Pollycoke – migliorare-la-leggibilita-dei-font-su-ubuntu-feisty. Seguendo questa guida avrete una emulazione del sistema ClearType di Windows su Ubuntu.

E’ tutto….divertitevi con il Cubo!

  • Se c’è qualcuno che prova questa procedura, non sarebbe male che commentasse se il tutto ha funzionato o no…grazie.

  • mastino

    ciao. ho provato e funziona con xgl + driver proprietari+ feisty. il problema è che si deve disabilitare i repo di universe perchè la versione dei repo universe non supporta i driver restricted.. come si fà ad aggiornare poi?

  • mmm..guarda io su synaptic in impostazioni -> archivi dei pacchetti ho tutti i repository abilitati (sia universe che restricted) ed aggiorno senza problemi.

  • monk

    Ciao. Ho una ATI mobility radeon X700, ma non riesco ad abilitare i driver proprietari. Infatti, andando in sistema/amministrazione/gestore driver con restrizioni mi dice che il mio hardware non ha bisogno di driver con restrizioni.
    Sapete aiutarmi?

  • mmm…siceramente non so che dirti…è strano che ti scriva così. Prova a chiedere sul forum di Ubuntu-it.org nella sezione “grafica”, forse loro ne sanno di più.

  • xes

    salve,
    ho kde e volevo sapere a cosa corrispondeva “Sistema -> Amministrazione -> Gestore driver con restrizioni” non ho proprio idea dv andare
    grazie

  • mitch

    save a tutti,
    ho una ati mobility radeon 9700, ho seguito la guida e tutto sembra andare bene: se eseguo il comando fglrxinfo mi scrive che i driver in uso sono i miei e compiz funziona!
    il mio problema è che volevo aumentare la definizione dello schermo a 1200X800 ma su imposta risoluzione dello schermo il massimo che mi permette di impostare è 1027×768… che è successo??
    grazie mille

  • mitch

    altro problema…lanciando il comando glxinfo | grep render mi dice direct rendering: no…
    aiuto!

  • Per quanto riguarda la risoluzione mi sa che il problema risiede nella configurazione del file xorg.conf…tra i commenti del post http://pollosky.wordpress.com/2007/04/20/ubuntu-feisty-vs-toshiba-m40la-sfida/ ho postato il mio file xorg.conf, forse puoi dare li un’occhiata per vedere se cambia qualcosa.

    Per quanto riguarda il direct rendering succede pure a me…dipende dalla sessione di avvio della grafica. Con il server Xgl il direct rendering è “no” mentre con la sessione “Run Xclient” è “yes”….cmq non ti devi preoccupare, evidentemente deve essere così.

  • mitch

    grazie mille! è bastato aggiungere “1200×800” in SubSection “Display e al riavvio la voce era disponibile!
    complimenti per la chiarezza e la tempestività

  • di niente….torna quando vuoi a far visita al blog…e se vuoi lascia anche un saluto nel guestbook. ciao.

  • Oggi ho testato questo tutorial su un Notebook Fujitsu-Siemens con scheda Ati Radeon 9700.

    Ci sono stati dei problemi con l’avvio di Xgl…alla fine la soluzione è stata riconfigurare Xorg per l’utilizzo dei driver non proprietari Ati e utilizzare aiglx.

    Sembra che i driver non proprietari sono stabili sulla 9700…invece con la mia X700 avevo avuto dei problemi e quindi ero ricorso all’utilizzo dei proprietari.

    Cmq io vi consiglio innanzitutto di testare gli effetti con i driver non proprietari Ati e se avete dei problemi seguite pure questo tutorial per vedere se con i driver proprietari la cosa funziona.

    Ciao.

  • Marco Rotella

    Funziona alla perfezione! Uso linux, Debian, da 6 anni, ma non sono mai stato così soddisfatto di una distro tanto quanto lo sono di questa feisty! E’ STUPENDA!!

  • Teh_Nameless

    Provato il wiki… Non ho problemi fino al lancio della sezione xgl: parte perfettamente ma una volta avviato il mio desktop non e accelerato:

    neo@matrix:~$ glxinfo | greprendering
    Xlib: extension “XFree86-DRI” missing on display “localhost:1.0”.
    bash: greprendering: command not found

    è normale? io arrivato qui mi sono fermato perke non mi sembra un buon segno :D

  • Teh_Nameless

    risolto alla fine è andato tutto bene grazie!!:D

  • Dario

    provato su ATI X1600+AMDX2 4400 feisty . Perfetto! Velocità effetti sublimi!

  • GRAAAAAZIEEEEEEEEEE!!!
    Ho una Radeon Mobility x700 su AMD Athlon 64 3000+, funziona tutto!!

  • Pingback: [Ubuntu] Compiz Fusion + Ati?…tutto regolare « P o l l o S k y()

  • beppe

    a me è sparito il tasto di spegnimento….. come si recupera ?

  • Hai letto bene la discussione sul forum che è segnalata nel post?…ad un certo punto c’è scritto:


    if you experience a bug where you have no restart/shutdown button in the shutdown menu then you need to edit startxgl.sh to this
    Code:

    #!/bin/sh
    Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
    DISPLAY=:1
    cookie=”$(xauth -i nextract – :0 | cut -d ‘ ‘ -f 9)”
    xauth -i add :1 . “$cookie”
    exec dbus-launch –exit-with-session gnome-session

    …è la soluzione al tuo problema.

  • Giuseppe

    Ho seguito passo dopo passo la guida, ma nel momento in cui avvio la sessione XGL ho dei disturbi sulla grafica del mio desktop.Cosa devo fare???

  • E’ un domandone questo…non è facile dirti da cosa possa dipendere. Se continui ad avere problemi puoi sempre disabilitare i driver proprietari e tornare ad utilizzare la vecchia sessione (senza XGL per intenderci).

  • Ciao.
    Ho seguito passo passo tutta la guida, ma quando provo ad avviare con l’XGL il server non parte e torna alla schermata di login. :(
    Che posso fare?
    Ho una X800XL

  • Prova a ricontrollare tutti i passi, magari trovi qualche errore nella deifnizione del file per la sessione XGL…cmq in teoria il server xgl dovrebbe partire senza problemi; controlla se il pacchetto è ben installato.
    A meno che con la tua scheda video le cose non funzionino diversamente…purtroppo a riguardo non so dirti niente.

  • Pingback: [Ubuntu] Schermo nero durante il caricamento di Gutsy…ecco una rapida soluzione « P o l l o S k y()

  • Nightwings

    ho cambiato server grafico seguendo la guida ma appena uso gli effetti grafici mi scompare la barra della finestra con le icone per la chiusura,ridimensionamento e minimizzazione…qualcuno mi sa spiegare il perchè

  • prova a testare differenti modi per avviare compiz attraverso la shell…magari prima prova a scrivere “compiz” o in alternativa prova “compiz –replace”…forse cambia qualcosa.

  • latynox

    mamma mia finalmente funziona tutto sulla mia ATI x600se…grazieee!!!!